Instalando o Flash Player no Linux x86_64, 64 bits.

Olá todos. Para a nossa alegria, a Adobe liberou novamente uma versão do flash player 64 para Linux.

Segue abaixo um tutorialsinho de como instalar o Adobe Flash Player de 64 bit na distribuição Linux que você usa.

Vamos fazer pelo terminal que neste caso é mais fácil. O link que está abaixo é da ultima versão disponível na data de escrita este tutorial. Para conferir a versão mais recente vá em labs.adobe.com

Os comandos que você deve digitar estão em negrito. Abra um terminal.

Baixe o Adobe Flash Player 64 bits em labs.adobe.com/downloads/flashplayer10.html:
Extraia ele:

tar -zxvf "nome do arquivo baixado.tar.gz"
Logue-se como root:

su

Após o su digite a senha do root e tecle enter, a senha não será exibida.
Copie o arquivo libflashplayer.so para a pasta de plugins do Linux:

cp libflashplayer.so /usr/lib64/mozilla/plugins

Reinicie seu navegador de internet.

Pronto, agora você já deve ter instalado a versão de 64 bits do Adobe Flash Player.

Qualquer dúvida, pergunte.

Anúncios

33 ideias sobre “Instalando o Flash Player no Linux x86_64, 64 bits.

  1. Diederick

    Só tem um problema, champz: alguns conteúdos com vídeo embedded, como os da BBC Brasil dão segfault no Firefox com este plugin (e talvez no Opera, se for problema do plugin mesmo). Pode ser que outros não funcionem também, mas não cheguei a testar todos.

    Eu, que uso Ubuntu (amd64), fiquei entre a cruz e a espada, porque o Flash dos repositórios falha aleatoriamente, e este do site da Adobe falha com alguns conteúdos. Ou o Linux é muito ruim pra multimídia ou a Adobe tem uma má vontade imensa para com o Flash em outras plataformas (o Flash do MacOS também é péssimo, segundo as más línguas cor-de-arco-íris). Talvez as duas hipóteses estejam corretas – com peso maior para a segunda, naturalmente.

    Curtir

  2. Renato Ferreira

    ai Megaf, desculpa entrar aqui no seu espaço ainda mais para tratar de um assunto que não tem nada haver com esse tutorial que voce fez(a não da parte que voce cita que recentemente adiquiriu o novo proc.), mas eu gostaria de saber se tem como a gente se falar, por msn, e-mail, ou qualquer outro meio, pois vi em um comentario seu no blog do Carlos Morimoto (que tambem cai de paraquedas procurando por overclock) que tu acabou de comprar um Phenom II 955 Black Edition, e eu gostaria de saber suas experiencias com ele e etc…

    se puder me responder por e-mail eu ficarei muito agradecido.
    abraço… sucesso ao blog.

    Curtir

  3. Diego

    Olá Megaf.
    Fiz a instalação conforme o teu procedimento acima descrito, porém agora meu Firefox fecha sozinho quando acesso qualquer site que possua flash.
    Sabe a solução para isso?

    Curtir

  4. Diego

    Notei outro detalhe.
    Na verdade não é qualquer site que possua flash que faz meu browser fechar sozinho.
    São em alguns sites apenas, como exemplo este daqui:

    Curtir

  5. Megaf Autor do post

    Olá Diego, Este site possui muito conteúdo em flash e muitos banners, talvez seja d+ ára o pobre Firefox, recomendo testar o Opera. http://www.opera.com

    PS, removi o link do site por que tem conteúdo muito forte para ser postado aqui.

    Curtir

  6. Megaf Autor do post

    Glênio, ok, mas este plugin aí não funciona em Linux 64 bits, pra Linux 64 bits precisa de uma outra versão do flash, que é a versão que eu falo aqui.

    Pra 32 bits é uma outra dica, que é exatamente o que tu fizestes. https://megaf.wordpress.com/2009/07/07/instalar-flash-player-no-mandriva/

    Mesmo assim, obrigado pelo comentário.

    Quem tiver aqui a procura do Flash de 32 bits, só seguir o link que o amigo Glênio colocou no comentário. 🙂

    Um abraço!

    Curtir

  7. Pingback: Mandriva – Dicas para usuários iniciantes. « Megaf Portal

  8. Megaf Autor do post

    Coiter, eu que agradeço pela sua disposição em comentar e agradecer. Isso que nos incentiva. 😉
    Obrigado!

    Curtir

  9. wildejr

    Pessoal, já tentei de tudo mas o meu ff 3.5 fecha sempre que acesso o youtube pra rodar algum vídeo. já instalei e desinstalei n vezes sem sucesso. Uso o mdv 2010. Alguem pode ajudar?

    Curtir

  10. Megaf Autor do post

    Olá wildejr,
    Tenta desinstalar o plugin gnash.
    Se não funcionar, tenta rodar o firefox no modo de segurança, com o parâmetro -safe-mode .
    Se ainda assim não funcionar, desinstala ele e reinstala.
    Se não der certo, use o Opera ou o Arora. 🙂

    Curtir

  11. wildejr

    Megaf, obrigado por tentar ajudar.
    O plugin gnash já estava desinstalado. Tentei rodar no modo de segurança e desabilitar os add-ons e também não funcionou.

    Usei o Opera então e embora ele não feche também não rodou os vídeos flash:

    [wjr@localhost ~]$ opera
    ERROR: ld.so: object ‘libjvm.so’ from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object ‘libawt.so’ from LD_PRELOAD cannot be preloaded: ignored.
    opera: Plug-in 8097 is not responding. It will be closed.
    opera: Define environment variable OPERA_KEEP_BLOCKED_PLUGIN to keep blocked plug-ins.

    O pessoal tem conseguido usar o mandriva 64 bits e ter resultados com o flash? Estou a um passo de voltar pra 32 bits. O site do banco do brasil também não funciona e já tentei tudo!!

    Curtir

  12. Megaf Autor do post

    wildejr, ok,

    Parece que o plugin que voce baixou não ta se comportando direito. procure pelo arquivo libflashplayer.so ou algo assim na pastas /usr/lib/mozilla/plugins ou em vez de lib, lib 64 e o delete.

    Depois adicione ass mídias PLF Free e Non Free.
    Só executar este comando no terminal.
    urpmi.addmedia –distrib –mirrorlist ‘http://plf.zarb.org/mirrors/$RELEASE.$ARCH.list’

    Depois urpmi flashplayer-plugin ou flash-plugin ou algo assim, não estou lembrado. 😛

    Da um urpmq -ya flash | grep player ou urpmq -ya flash | grep plugin

    Então fexe os browsers e tente novamente.

    Ah, no Opera, vai nas preferencias, la em plugins, e desmarca o diretorio da pozilla, deixa só o do Opera habilitado.

    Curtir

  13. Canonical

    Lucas Popenke Paes

    reformule sua pergunta.

    diga que erro aparece

    que msgs esta retornando.

    qual seu sistema, qual sua versao.

    ????

    Curtir

  14. Pingback: Removendo o plugin flash que vem instalado no Mandriva e em outras distros. « Megaf Portal

  15. Megaf Autor do post

    E essa é uma das únicas maneiras atualmente, já que a Adobe deu uma pausa no flash 64 pra Linux.

    Curtir

  16. Pingback: Adobe lança preview do Flash Player de 64-bit para IE9, Linux e Mac « Megaf.Info

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s