Laptops problemáticos com GNU/Linux

Olá. Venho recebendo pedidos de ajuda de muita gente que acabou de comprar um laptop e foi instalar GNU/Linux ou atualizar o sistema e teve algum tipo de problema, seja o servidor gráfico não subir mais ou o drive de cd que não abre ou o som que não funciona. Com base nisso, decidi abrir este tópico para criar uma espécie de black list comunitária de laptops que não são recomendados para quem quer usar Linux.

Caso você tenha um laptop e já está penando a algum tempo pra fazer ele funcionar como deveria, diga para nós o modelo dele e o fabricante, assim outras pessoas que também querem usar GNU/Linux poderão melhor escolher o laptop a comprar.

Já adiantando, informo que laptops com placas gráficas dos fabricantes SIS e VIA não são nada recomendados, nem pra rodar o sistema proprietário!

Anúncios

42 ideias sobre “Laptops problemáticos com GNU/Linux

  1. Gilmar

    Olá Megaf,

    Boa iniciativa. Tenho um netbook Acer One onde não consigo conectar pela placa wireless.

    Att
    Gilmar

    Curtir

  2. Émerson

    Opa,

    No Microboard Ellite Premium:

    Funciona tudo muito bem, com exceção da webcam onboard que fica com uma imagem “verde” e bem escura.

    Abraço.

    Curtir

  3. EJPS

    Boa,

    Comprei um Philco (com SIS) que veio com Mandriva instalado, o microfone não chegou a funcionar e logo vídeo e alguns progamas também foram deixando de funcionar. Na primeira atualização o sistema não carregou mais.

    Falou

    Curtir

  4. Paulo Sante

    Acer One com o Mandriva 2009.1 One. Ele instala perfeitamente mas o driver gráfico não é bom. A imagem na tela não fica muito legal, mas funciona perfeitamente.
    Não é um netbook problemático, mas até a versão 2009.1 tinha essa ressalva para os olhares mais críticos do Linux.
    Abraços!

    Curtir

  5. Megaf Autor do post

    @Gilmar, Olá, obrigado. Cara, o Acer não era pra ser problemático não, qual distribuição tu testaste nele?

    Curtir

  6. Vagner Sanches Vasconcelos

    Lenovo ThinkPad R21.

    Ubuntu 9.10
    Funciona tudo perfeitamente bem.

    Abraços,
    Vagner

    Curtir

  7. mourdok

    Tenho um Notebook da AmazonPC que sempre perde a conexão Wi-Fi.

    Ele esta com a versão 9.10 do Ubuntu.

    O que encontrei de resposta até agora, foi que a fabricante da placa Wi-Fi não da suporte (que se preze) para Linux.

    Curtir

  8. Megaf Autor do post

    @Vagner Obrigado, esse vai pra white list em vez de black list. Os ThinkPad geralmente funcionam perfeitamente mesmo. 🙂

    @mourdok Sabe qual é a placa de rede sem fio dele?

    @Marcelo Pois é, neste caso, aquela frase: Começou Comprando Errado, é verdadeira para quem quer usar Linux. Mas que eles são bonitos, isso são.

    Curtir

  9. Alectronix

    ACTEON (CCE) ACK-52C – SiS 771/671

    O Hardware é bem limitado, mas funciona muito bem
    no Mandriva One 2010 e 2010.1 beta1, inclusive com uma agradável configuração
    automática do modo gráfico – não precisei realizar quaisquer ajustes.

    Já no Ubuntu, às vezes, nem inicia o live cd em modo gráfico e, quando inicia,
    a configuração gráfica é horrivel – preciso instalar pacotes adicionais que só encontrei
    para versão 32bits… No OpenSuse inicia com uma configuração não agradável, mas bem melhor
    do que a do Ubuntu (8.x ou 9.x).

    Demais dispositivos, inclusive wireless, funcionam sem problemas no Mandriva. O wireless também
    não funciona no Ubuntu (8.x, 9.x).

    Limitação: chipset gráfico, o 3D, por culpa da SiS, claro.

    Bem, definitivamente, o Mandriva 2010 deu uma goleada nas outras neste notebook!

    Curtir

  10. Lutemberg

    Olá Megaf! Já sou usuario dos seus tutoriais e seu utilíssimo site sobre GNU/Linux. O meu Acer Aspire One (netbook) está com o Mandriva 2010.0 Free e não consigo fazer funcionar o WiFi. Ainda não encontrei a solução e tentei muita coisa, inclusive se vc souber…

    Curtir

  11. Lutemberg

    Só acrescentando a placa WiFi do Acer One Aspire é uma Atheros 5001, instalei o driver pelo ndiswrapper, modulo ath5k. A placa é reconhecida mas não funciona.

    Curtir

  12. Megaf Autor do post

    Lutemberg, tu deverias ter tentado somente uma coisa, quando começa misturar as coisas tudo complica.

    Desistale o dni e o madwifi, depois reinicie e rode um dmesg | grep ath5k para ver se o ath5k tá rodando,
    tente um iwconfig também para ver se a placa de rede aparece lá como ath0 ou wlan0.

    Curtir

  13. Lutemberg

    Olá Megaf, obrigado pela dica. Ocorre que antes que eu tentasse o que vc falou, o WiFi passou a funcionar inexplicavelmente… pode ser que havia algum erro na configuração da rede, não sei. Fui insistindo, no modo gráfico mesmo, e agora tá funcionando. Só não acende o led que indica o funcionamento do wifi. Mas isso é o de menos!

    []’s

    Curtir

  14. Megaf Autor do post

    Lutemberg, Inexplicavelmente, sei…

    hehe, to brincando, vai ver tu tinha atualizado o sistema e precisava reiniciar pra entrar algo em vigor, ou veio algo que fez funcionar em algum update, ou tu fuçou tanto que acabou conseguindo configurar e nem viu. 😛

    Curtir

  15. Lutemberg

    Sei…sei… hehehe. Curioso é que outras pessoas aqui apontaram o tal problema com wifi do mesmo net, né?! Agora descobri o tuningdrake pra resolver os problemas de video na internet. Simplesmente fantástico, resolve tudo como que num passe de mágica!

    Curtir

  16. Megaf Autor do post

    Lutemberg, mágica é tu mesmo conseguir resolver todos os problemas, e facilmente, sem precisar recorrer a essas ferramentas de terceiros. 🙂

    Curtir

  17. Lutemberg

    Não exagera Megaf, quem sabe um dia eu chego lá… gente como vc é que nos anima a continuar aprendendo esse negócio de software livre…

    Bem, então, “on-topic”, meu Acer Aspire One saiu da lista (minha) de problemáticos, está com tudo funcionando, inclusive aquele led que eu disse aí em cima que não acendia, do wifi. Não é incrível??!!! Por favor, eu sou quase normal!!! Ele não acendia!!! Estou usando o Compiz-Fusion com todos recursos e está tudo rodando bem.

    “off-topic”: instalei o Lotus Symphony tudo bonitinho, ícone no lançador de aplicativos, blz. Só que não abre… é a versão 1.3 que baixei no site do desenvolvedor (IBM). Se alguém souber de alguma coisa… instalei no Vista e está normal. Agora saiu o 3 beta, vou dar uma olhada…

    []’s

    Curtir

  18. Megaf Autor do post

    Lutemberg, a mágica consiste em não desistir e buscar aquilo que se quer. E isso não vale somente pro Mandriva. 😉

    Se tu quiser dominar este fantástico sistema, só ir usando ele e explorando. Daqui apocou tu vai se ver livre completamente de coisas proprietárias, como o Windows e o Microsoft Office.

    Curtir

  19. Sergio

    Tenho um note Z560 da Positivo que funciona tudo redondinho com o Madriva 2010. Uma beleza, mesmo com placa SIS.
    Tentei instalar o Ubuntu 4.10, mas não aceita a dita placa.

    Curtir

  20. Megaf Autor do post

    Sérgio, de fato o Mandriva está entre os sistemas operacionais que suporta uma maior quantidade de dispositivos, foi a primeira distro a suportar completamente o Asus Eee PC e os outros netbooks, e ainda hoje, se não me engano, é a única que suporta o Eee 100%, sem a necessidade de qualquer configuração. O Mandriva suporta esses netbooks desde o 2008.1 (Mandriva 2008 Spring).

    Curtir

  21. yermandu

    Placa de rede Realtek rtl8187b

    Bus 002 Device 003: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter

    Curtir

  22. Lutemberg

    Lembram daquele Acer Aspire One lá de cima? Pois é. Atualizei pro Mandriva 2010.1 on-line, só mudando os repositórios. Fantástico, achei muito legal isso!!! Só que com a atualização não consegui mais ver videos em tela cheia no Youtube (video Intel 945G). Desabilitei aqueles efeitos bonitinhos do Compiz e agora funciona. Mas não deveria ter acontecido, pois antes da atualização funcionava TUDO!!

    Curtir

  23. Megaf Autor do post

    yermandu
    Essa placa está deixando muita gente frustrada mesmo.

    Lutemberg
    Como assim não consegue? A interface gŕafica fica toda embaralhada zoada ou fica lento ou que?

    Curtir

  24. Lutemberg

    Megaf, o video roda 2 ou 3 segundos e trava. Tirando da tela cheia ele volta a rodar. Desabilitei os efeitos e funcionou…

    Curtir

  25. Megaf Autor do post

    francisco Pode ser muita coisa, teu laptop não ter essa capacidade, tu não ter o driver 3D instalado, ou o plugin flash estar ruim mesmo. Qual é o laptop que tu tem? qual linux tu ta usando?

    Curtir

  26. awtrix

    notebook acer aspire 4736z, funcionava tudo ateh o kernel 2.6.38

    agora o monitor naum funciona mais, e quando aperta para desligar direto no botao ele pisca e vc ve a tela de login no fundo

    ja tentei de tudo ateh pular esse kernel direto para o 2.6.39 que funcionou umas 3 vezes, no quarto ciclo de liga e desliga aconteceu a mesma coisa

    uma pena ja q antes funcionava tudo perfeitamente.

    Curtir

  27. yermandu

    Olá Megaf, a proposito a placa rtl8187 esta funcionando no kernel .38 =)

    awtrix, pode ser tanta coisa, já tentou voltar para o último kernel em funcionamento? Ou o ultimo estable 2.6.37.6? Minha placa de video não funciona no .39, o computador nem dá o boot. No seu caso talvez possa ser o drive Xorg … se o monitor funciona no console mas não vai para o modo grafico então é o problema é com o X. Tente iniciar pelo console, depois vá para o init 5, se der problemas está certo que o problema esta no drive X, então tente fazer um downgrade do driver, ou um update.
    Boa Sorte

    Megaf Abraço

    Curtir

  28. awtrix

    na verdade eu naum estou conseguindo me explicar.

    esta tudo ok, forçando bem a vista vc ve no fundo a tela do logon no caso do ubuntu, mas o monitor fica muito escuro, ja tentei ateh aumentar o brilho achando q fosse algum problema deste tipo.

    naum eh q o monitor naum liga, na verdade ele naum brilha vc ateh ve o fundo dependendo da luz do ambiente.

    ateh cheguei a achar q era configuraçao de energia alguma coisa assim, mas naum ta dando jeito.

    com o kernel 2.6.39 ele ateh funcionou umas 3 vezes mas depois aconteceu a mesma coisa. estou usando o kernel 2.5.38 do maverik vamos ver ateh quando isso vai hehehehhe

    Curtir

  29. awtrix

    ops
    $ uname -r
    errei hehehe

    kernel 2.6.35-28-generic dai pra frente fui de um em um mas naum deu mesmo

    obrigado

    Curtir

  30. Megaf Autor do post

    Fala yermandu, então cara, eu tava compilando o kernel .38 e .39 esses dias mesmo e reparei que tem um monte de modulo novo sobre as 8187, o .39 parece ainda melhor que o .38.

    Curtir

  31. yermandu

    Eu to no .38 pq o .39 ta zicado com minha placa de video intel i915 #Fail
    Realmente para o .39 recebeu algumas pequenas correções, mas é uma placa difícil de funcionar no linux, fiz alguns testes e ela mantém o sinal instável variando de 40 kbps para 20 kbps depois para 30kbps volta para 2kpbs sobe para 10, desce para 2bps , enfim muito instável ainda mais com um roteador dlink, mas decobri que reconectando algumas vezes ela fica um pouco normal, o sinal variante mas é possivel permacer conectado por horas sem cair. Recebi um email do lkml que eles dizem que o problema é físico mesmo, eles fizeram o melhor que puderam para deixar o driver funcionando. Minha solução para downloads grandes foi puxar um cabo de rede até minha mesa e quando preciso fazer downloads pesados uso conexão via cabo.
    Espero chegar logo no .39 🙂
    abrass

    Curtir

  32. Ailton Soares

    ola

    o meu pc é Acer Aspire 5732Z

    depois de instalar o Mandriva 2011 a tela fica preta apartir da tela de login. por favor se puder me ajude porque ta fazendo muita falta mesmo

    Curtir

  33. Megaf Autor do post

    Olá Ailton Soares.
    Muito estranho isso acontecer, o teu notebook tem uma placa de vídeo bem suportada pelas distribuições Linux.
    Tu pode testar o Mageia Linux e ver se acontece a mesma coisa? O Mageia uma continuação do Mandriva Linux, mas mantida exclusivamente pela comunidade, sem controle da empresa Mandriva.

    http://www.mageia.org/pt-br/

    Curtir

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s